DHCP Relay

DHCP Relay

DHCP সার্ভার যখন DHCP ক্লায়েন্ট থেকে আলাদা ব্রডকাস্ট ডোমেইনে থাকে তখন DHCP Relay কনফিগার করতে হয়। বাই ডিফল্ট রাউটার ব্রডকাস্ট প্যাকেট ফরওয়ার্ড করে না কিন্তু DHCP প্যাকেট গুলো ব্রডকাস্ট হওয়ায় রাউটার প্যাকেটগুলোকে ড্রপ করে দেয়। DHCP এই ব্রডকাস্ট প্যাকেটগুলোকে রাউটার হতে Unicast করে DHCP সার্ভার পর্যন্ত পৌঁছানোর জন্য DHCP Relay Agent ক্রিয়েট করা হয়।

Configuration:

Head Office Router:

Head_Office(config)#
Head_Office(config)#interface gigabitEthernet 0/0
Head_Office(config-if)#ip address 103.160.20.2 255.255.255.252
Head_Office(config-if)#no shutdown
Head_Office(config-if)#exit
Head_Office(config)#
Head_Office(config)#interface gigabitEthernet 0/1
Head_Office(config-if)#ip address 192.168.0.1 255.255.255.0
Head_Office(config-if)#no shutdown
Head_Office(config-if)#exit
Head_Office(config)#
Head_Office(config)#ip route 0.0.0.0 0.0.0.0 103.160.20.1

Head_Office(config)#
Head_Office(config)#ip dhcp pool For_Branch
Head_Office(dhcp-config)#network 172.16.0.0 255.255.255.0
Head_Office(dhcp-config)#default-router 172.16.0.1
Head_Office(dhcp-config)#dns-server 8.8.8.8
Head_Office(dhcp-config)#exit
Head_Office(config)#
Head_Office(config)#ip dhcp pool For_Head_Office
Head_Office(dhcp-config)#network 192.168.0.0 255.255.255.0
Head_Office(dhcp-config)#default-router 192.168.0.1
Head_Office(dhcp-config)#dns-server 8.8.8.8
Head_Office(dhcp-config)#exit
Head_Office(config)#

Branch_Router:

Branch_Router(config)#
Branch_Router(config)#interface gigabitEthernet 0/0
Branch_Router(config-if)#ip address 103.160.20.1 255.255.255.252
Branch_Router(config-if)#no shutdown
Branch_Router(config-if)#exit
Branch_Router(config)#
Branch_Router(config)#interface gigabitEthernet 0/1
Branch_Router(config-if)#ip address 172.16.0.1 255.255.255.0
Branch_Router(config-if)#ip helper-address 103.160.20.2
Branch_Router(config-if)#no shutdown
Branch_Router(config-if)#do wr
Branch_Router(config-if)#exit
Branch_Router(config)#

Result:

By | 2021-04-02T19:00:47+06:00 December 7th, 2020|LAB|3 Comments

About the Author:

3 Comments

  1. Rabiul December 7, 2020 at 12:54 am - Reply

    This concept is really helpful for us. Thanks to you for sharing with us.

  2. Lindsey September 2, 2021 at 4:34 am - Reply

    Hmm is anyone else having problems with the pictures on this blog loading?
    I’m trying to figure out if its a problem on my end or if
    it’s the blog. Any feedback would be greatly appreciated.

    • Md Hedaet Shake September 2, 2021 at 2:26 pm - Reply

      Thank you for visiting our blog, hope you’ll be with us & we will consider your matter 🙂

Leave A Comment