Inter-Vlan

Inter-Vlan

আমরা যখন Layer 2 Switch এ Multiple Vlan Create করি তখন Vlan গুলো পরস্পরের সাথে Communication করতে পারে না। একই Vlan এর ইউজারগুলো পরস্পরের সাথে Communication করতে পারবে। এখন যদি এমন হয় একটি Vlan এর ইউজারগুলো অন্য একটি Vlan এর ইউজারগুলো সাথে Communication করতে চায়, তাহলে Inter-Vlan করতে হবে। Inter-Vlan করলে Multiple Vlan এর ইউজারগুলো পরস্পরের সাথে Communicate এ করতে পারবে।

Inter-Vlan করতে হলে অবশ্যই একটি Layer 3 ডিভাইস লাগবে। Layer 3 ডিভাইসে Sub-Interface(SVI) create করে , অথবা Physical Interface এ Vlan অনুযায়ী IP Address Assign করতে হবে। এই IP Address হবে ঐ Vlan এর ইউজার গুলোর Gateway।
Suppose, নেটওয়ার্কে 3টি Vlan আছে। এই 3টি Vlan এর জন্য, Layer 3 ডিভাইসে Sub-Interface(SVI) করে হোক বা Physical Interface এ হোক 3টি ভিন্ন নেটওয়ার্ক এর IP Address Assign করতে হবে । যে Vlan এর জন্য যে IP Address Assign করব , ঐ IP Address হবে ঐ Vlan এর ইউজারের Gateway।

Layer 3 ডিভাইস হিসাবে Router অথবা Layer-3 Switch ব্যবহার করতে পারি। যদি Layer-3 Switch ব্যবহার করি তাহলে “IP Routing” Command দিতে হবে। Router ব্যবহার করলে এই Command দেওয়া লাগবে না।

LAB-1:

Router ব্যবহার করে Inter-Vlan Configure:

Configure

Router:

Router>enable
Router#configure terminal

Router(config)#interface gigabitEthernet 0/0.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#exit

Router(config)#interface gigabitEthernet 0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config-subif)#exit

Router(config)#interface gigabitEthernet 0/0.30
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 192.168.30.1 255.255.255.0
Router(config-subif)#exit

Router(config)#interface gigabitEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#do wr

Switch:

Switch>enable
Switch#configure terminal

Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#exit

Switch(config)#interface range fastEthernet 0/1-2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/3-4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/5-6
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#exit

Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#do wr

Note: Topology অনুযায়ী PC গুলতে IP Address, Subnet Mask & Gateway Assign করতে হবে।

For Vlan 10
IP Address: 192.168.10.0/24
Gateway:192.168.10.1

For Vlan 20
IP Address: 192.168.20.0/24
Gateway:192.168.20.1

For Vlan 30
IP Address: 192.168.30.0/24
Gateway:192.168.30.1

Result:

LAB-2:

Layer-3 Switch ব্যবহার করে Inter-Vlan Configure:

Configure

Layer-3 Switch:

Switch>ena
Switch#configure terminal

Switch(config)#hostname L3_Switch

L3_Switch(config)#vlan 10
L3_Switch(config-vlan)#exit
L3_Switch(config)#vlan 20
L3_Switch(config-vlan)#exit
L3_Switch(config)#vlan 30
L3_Switch(config-vlan)#exit

L3_Switch(config)#interface vlan 10
L3_Switch(config-if)#ip address 192.168.10.1 255.255.255.0
L3_Switch(config-if)#exit

L3_Switch(config)#interface vlan 20
L3_Switch(config-if)#ip address 192.168.20.1 255.255.255.0
L3_Switch(config-if)#exit

L3_Switch(config)#interface vlan 30
L3_Switch(config-if)#ip address 192.168.30.1 255.255.255.0
L3_Switch(config-if)#exit

L3_Switch(config)#interface fastEthernet 0/1
L3_Switch(config-if)#switchport trunk encapsulation dot1q
L3_Switch(config-if)#switchport mode trunk
L3_Switch(config-if)#exit

L3_Switch(config)#ip routing

L3_Switch(config)#do wr

Switch:

Switch>
Switch>enable
Switch#configure terminal

Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#exit

Switch(config)#interface range fastEthernet 0/1-2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/3-4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/5-6
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#exit

Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#do wr

Note: Topology অনুযায়ী PC গুলতে IP Address, Subnet Mask & Gateway Assign করতে হবে।

For Vlan 10
IP Address: 192.168.10.0/24
Gateway:192.168.10.1

For Vlan 20
IP Address: 192.168.20.0/24
Gateway:192.168.20.1

For Vlan 30
IP Address: 192.168.30.0/24
Gateway:192.168.30.1

Result:

Download Configuration:
For open configuration file, recommended packet tracer version is 8.0.0

Have Any query Please Comment Below

By | 2021-03-25T00:42:46+06:00 March 22nd, 2021|Networking|0 Comments

About the Author:

Leave A Comment