Telnet & SSH

Telnet & SSH

Management প্রটোকল এর মধ্যে সবথেকে বেশি ব্যবহৃত হয় Telnet এবং SSH । এই দুইটা প্রটোকলের মাধ্যমে রিমোটলি ডিভাইসগুলোকে ম্যানেজ করা হয়। Telnet এবং SSH প্রটোকল দুটো ব্যবহার করে আমরা ডিভাইজের কাছে না থেকেও ওই ডিভাইসকে আমাদের প্রয়োজন মতো কনফিগার ও ম্যানেজ করতে পারি।

Telnet ও SSH প্রটোকল দুটির কাজ একই কিন্তু এদের মধ্যে মেজর একটি পার্থক্য রয়েছে. Telnet এর ক্ষেত্রে link এর মধ্যে দিয়ে ডাটা গুলো plain text অবস্থায় যায়। অর্থাৎ ডাটা গুলো Encrypted হয় না। SSH এর ক্ষেত্রে link এর মধ্যে দিয়ে ডাটা গুলো Encrypted হয়ে যায়। এ ক্ষেত্রে Telnet এর চেয়ে SSH অনেক বেশি secure.

নিচে Telnet&SSH এর ছোট একটা কনফিগারেশন দেখানো হলো:

SW-1:

SW-1(config)#enable password cisco
SW-1(config)#username cisco password cisco

SW-1(config)#ip domain-name cisco.net
SW-1(config)#crypto key generate rsa
How many bits in the modulus [512]: 1024
SW-1(config)#line vty 0 4
SW-1(config-line)#transport input all
SW-1(config-line)#password cisco
SW-1(config-line)#login local
SW-1(config-line)#exit

SW-1(config)#vlan 10
SW-1(config-vlan)#name MGT
SW-1(config-vlan)#exit

SW-1(config)#interface vlan 10
SW-1(config-if)#ip address 192.168.0.1 255.255.255.0
SW-1(config-if)#exit

SW-1(config)#interface fastethernet 0/1
SW-1(config-if)#switchport access vlan 10
SW-1(config-if)#exit

SW-1(config)#interface fastethernet 0/2
SW-1(config-if)#switchport trunk encapsulation dot1q
SW-1(config-if)#switchport mode trunk
SW-1(config-if)#do wr

SW-2:

SW-2(config)#enable password cisco
SW-2(config)#username cisco password cisco

SW-2(config)#ip domain-name cisco.net
SW-2(config)#crypto key generate rsa
How many bits in the modulus [512]: 1024
SW-2(config)#line vty 0 4
SW-2(config-line)#transport input all
SW-2(config-line)#password cisco
SW-2(config-line)#login local
SW-2(config-line)#exit

SW-2(config)#vlan 10
SW-2(config-vlan)#name MGT
SW-2(config-vlan)#exit

SW-2(config)#interface vlan 10
SW-2(config-if)#ip address 192.168.0.2 255.255.255.0
SW-2(config-if)#exit

SW-2(config)#interface fastethernet 0/1
SW-2(config-if)#switchport trunk encapsulation dot1q
SW-2(config-if)#switchport mode trunk
SW-2(config-if)#exit
SW-2(config)#interface fastethernet 0/2
SW-2(config-if)#switchport trunk encapsulation dot1q
SW-2(config-if)#switchport mode trunk
SW-1(config-if)#do wr

SW-3:

SW-3(config)#enable password cisco
SW-3(config)#username cisco password cisco

SW-3(config)#ip domain-name cisco.net
SW-3(config)#crypto key generate rsa
How many bits in the modulus [512]: 1024
SW-3(config)#line vty 0 4
SW-3(config-line)#transport input all
SW-3(config-line)#password cisco
SW-3(config-line)#login local
SW-3(config-line)#exit

SW-3(config)#vlan 10
SW-3(config-vlan)#name MGT
SW-3(config-vlan)#exit

SW-3(config)#interface vlan 10
SW-3(config-if)#ip address 192.168.0.3 255.255.255.0
SW-3(config-if)#exit

SW-3(config)#interface fastethernet 0/1
SW-3(config-if)#switchport trunk encapsulation dot1q
SW-3(config-if)#switchport mode trunk
SW-3(config-if)#exit
SW-3(config)#interface fastethernet 0/2
SW-3(config-if)#switchport trunk encapsulation dot1q
SW-3(config-if)#switchport mode trunk
SW-3(config-if)#do wr

Remote Pcতে একই নেটওয়ার্কের আইপি বসিয়ে কানেক্টিভিটি চেক করবেন।

Telnet ও SSH connect করার জন্য নিন্ম তথ্য গুলো প্রয়োজন :
IP Address
Username
Password

Result:

Remote user এর উপর ক্লিক করে Desktop>Command Prompt

Telnet: telnet “IPAddress”

SSH: ssh -l “username” “IP Address”

.pkt configuration file প্রয়োজন হলে কমেন্ট করে জানাবেন।

Telnet&SSH সম্পর্কে আরো বিস্তারিত জানতে আমাদের কন্টাক্ট ফর্মটি পূরণ করে সাবমিট করুন।

By | 2021-04-02T19:11:43+06:00 November 25th, 2020|Networking|14 Comments

About the Author:

14 Comments

  1. Rozella September 1, 2021 at 12:33 am - Reply

    Very descriptive post, I liked that bit.
    Will there be a part 2?

  2. Vitória September 2, 2021 at 12:41 am - Reply

    Vocês não sabem quanto já procurei por um blog
    que falasse sobre isso de forma simples como você
    fizeram . Deixo registrado aqui o meu sinceros
    agradecimentos

    • Md Hedaet Shake September 2, 2021 at 1:41 pm - Reply

      Thank you for visiting our blog, hope you’ll be with us 🙂

  3. Elisabeth September 2, 2021 at 1:03 am - Reply

    Hello There. I found your blog using msn. This is a really well written article.
    I’ll make sure to bookmark it and return to read more of your useful information. Thanks for the post.
    I will certainly comeback.

  4. Clayton September 2, 2021 at 1:24 am - Reply

    Hello colleagues, fastidious paragraph and good urging commented at this place, I am in fact enjoying by these.

    • Md Hedaet Shake September 2, 2021 at 2:05 pm - Reply

      Thank you for visiting our blog, hope you’ll be with us 🙂

  5. Elvia September 2, 2021 at 2:01 am - Reply

    You could definitely see your enthusiasm in the work you write.

    The world hopes for even more passionate
    writers like you who are not afraid to mention how they believe.
    At all times follow your heart.

  6. instagram takipçi satın al September 2, 2021 at 2:07 am - Reply

    Nice post. I learn something new and challenging on blogs I stumbleupon everyday.
    It’s always exciting to read through content
    from other authors and practice something from other websites.

  7. Arnoldo September 2, 2021 at 4:05 am - Reply

    Outstanding post however , I was wanting to know if you could write a
    litte more on this topic? I’d be very grateful if you could elaborate a
    little bit more. Bless you!

    • Md Hedaet Shake September 2, 2021 at 2:25 pm - Reply

      Thank you for visiting our blog, hope you’ll be with us 🙂

Leave A Comment