Hot Standby Router Protocol

Hot Standby Router Protocol

যখন আমাদের নেটওয়ার্কে মাল্টিপল রাউটার থাকে তখন নেটওয়ার্কে একাধিক গেটওয়ে হওয়ার কারনে অ্যাক্টিভ রাউটার ডাউন হয়ে গেলে standby রাউটার দিয়ে অটোমেটিক ট্রাফিক পার হবে না,ট্রাফিক পার করার জন্য ইউজারের গেটওয়ে ম্যানুয়ালি পরিবর্তন করতে হবে, এই সমস্যা সমাধানের জন্য HSRP কনফিগার করা হয়। HSRP রাউটারের মধ্যে একটি ভার্চুয়াল গেটওয়ে তৈরি করে এবং একটি ভার্চুয়াল ম্যাক অ্যাড্রেস জেনারেট করে 0000.0c07.acxx (xx is group id)। এই ভার্চুয়াল গেটওয়ে ব্যাবহার করে সব ইউজার গুলো ইন্টারনেট অ্যাক্সেস করতে পারে। ভার্চুয়াল গেটওয়ে তৈরি হওয়ার কারনে অ্যাক্টিভ রাউটার ডাউন হলে standby রাউটার তখন অ্যাক্টিভ রাউটার হয়ে যাবে।HSRP Cisco Proprietry Protocol যা শুধুমাত্র Cisco Device এ Support করবে।

HSRP Neighbor Establishment Process: একই গ্রুপে থাকা রাউটার গুলোর মধ্যে Neighbor Establishment জন্য রাউটার গুলো 3sec পর পর একটা হ্যালো মেসেজ জেনারেট করে, এই হ্যালো মেসেজ জেনারেটএর জন্য Multicast Address 224.0.0.2 ও UDP 1985 Port নাম্বার ব্যাবহার করে। Hold interval Timer 10 sec.

HSRP 3 States:
listening
Standby
Active

HSRP প্রটোকলে Maximum group id support করে 0-255 টা। একটি গ্রুপে সর্বোচ্চ ৮টি রাউটার থাকতে পারবে। গ্রুপে একটি মাত্র রাউটার Active State এ থাকবে, একটি Standby State এ থাকবে বাকি সব গুলো রাউটার listening State এ থাকবে।

Election Process: একই গ্রুপে থাকা রাউটার গুলোর মধ্যে যে রাউটারে Priority Highest হবে ওই রাউটার Active State এ থাকবে, বাকি রাউটার গুলোর মধ্যে যে রাউটারে Priority Highest হবে ওই রাউটার Standby State এ থাকবে। বাকি রাউটার গুলো Listening State এ থাকবে। Bydefault রাউটার এর Priority ১০০ থাকে।
রাউটার গুলোর Priority একই হলে তখন IP Address এর উপর base করে Election হয় , যে রাউটার এর IP Address Highest হবে ওই রাউটার Active State এ থাকবে, বাকি রাউটার গুলোর মধ্যে যে রাউটারে IP Address Highest হবে ওই রাউটার Standby State এ থাকবে। বাকি রাউটার গুলো Listening State এ থাকবে।
Bydefault Preemption disable থাকার কারনে 10sec এর মধ্যে সব গুলো রাউটারে HSRP Configure না করলে প্রথমে যে রাউটার Active Stateএ চলে যাবে ওই রাউটার Active Stateএ থাকবে, Election হবে standby আর listening State এর মধ্যে । Preemption enable থাকলে Highest Priority উপর Depend করে ৩টি State এর মধ্যে Election হবে। Preemption enable করার কমান্ড Router(config-if)#standby 0 preempt .

LAB:

R1:

R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip address 192.168.0.1 255.255.255.0
R1(config-if)#standby 0 ip 192.168.0.100
R1(config-if)#standby 0 priority 200
R1(config-if)#standby 0 preempt
R1(config-if)#no shutdown

R1(config)#int gig 0/1
R1(config-if)#ip address 3.3.3.1 255.255.255.252
R1(config-if)#no shutdown

R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 3.3.3.0 255.255.255.252
R1(config-router)#network 192.168.0.0 255.255.255.0

R2:

R2(config)#interface gigabitEthernet 0/0
R2(config-if)#ip address 192.168.0.2 255.255.255.0
R2(config-if)#standby 0 ip 192.168.0.100
R2(config-if)#standby 0 priority 150
R2(config-if)#standby 0 preempt
R2(config-if)#no shutdown

R2(config)#int gig0/1
R2(config-if)#ip address 2.2.2.1 255.255.255.252
R2(config-if)#no shutdown

R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 2.2.2.0 255.255.255.252
R2(config-router)#network 192.168.0.0 255.255.255.0

R3:

R3(config)#interface gigabitEthernet 0/0
R3(config-if)#ip address 192.168.0.3 255.255.255.0
R3(config-if)#standby 0 ip 192.168.0.100
R3(config-if)#standby 0 priority 100
R3(config-if)#standby 0 preempt
R3(config-if)#no shutdown

R3(config)#int gig 0/1
R3(config-if)#ip address 1.1.1.1 255.255.255.252
R3(config-if)#no shutdown

R3(config)#router eigrp 1
R3(config-router)#no auto-summary
R3(config-router)#network 1.1.1.0 255.255.255.252
R3(config-router)#network 192.168.0.0 255.255.255.0

ISP:

ISP(config)#interface loopback 0
ISP(config-if)#ip address 8.8.8.8 255.255.255.0

ISP(config-if)#int gig 0/0
ISP(config-if)#ip address 3.3.3.2 255.255.255.252
ISP(config-if)#no shutdown

ISP(config-if)#exit
ISP(config)#int gig 0/2
ISP(config-if)#ip address 1.1.1.2 255.255.255.252
ISP(config-if)#no shutdown

ISP(config-if)#exit
ISP(config)#int gig 0/1
ISP(config-if)#ip address 2.2.2.2 255.255.255.252
ISP(config-if)#no shutdown

ISP(config)#router eigrp 1
ISP(config-router)#no auto-summary
ISP(config-router)#network 8.8.8.0 255.255.255.0
ISP(config-router)#network 1.1.1.0 255.255.255.252
ISP(config-router)#network 2.2.2.0 255.255.255.252
ISP(config-router)#network 3.3.3.0 255.255.255.252

Verify Configuration:

R1
R2
R3

Result:

Have Any Query Please Comment Below.

By | 2021-03-31T22:19:05+06:00 January 15th, 2021|Networking|0 Comments

About the Author:

Leave A Comment